What’s causing FZ750’s fuelling problem?

By MCN -

Parts & accessories

 09 July 2012 17:10

Q. I've got a technical problem with my 1986 Yamaha FZ750. Everything was fine until I removed the radiator to spray it, and then add new coolant. Whilst the radiator was off, I cleaned up the HT leads.

The engine started up OK, but the tickover was a bit slow, so I adjusted the adjustment screw and this is when I realised I had a problem. When I screwed it in, the engine started missing. Everything seemed fine above 2000 revs, but when shutting off, it also seemed to take its time slowing down between 2000 - 1000 revs.

When I first start it on choke, all appears OK but as it warms up, this problem appears.

I've changed the spark plugs (they all spark OK) checked the wiring and the carb diaphragms are all OK. Could some grit have found its way into a carb jet?
Jez Smailes, email

A. It does sounds like a carburation/choke issue. The choke assemblies on 80s and 90s Yamahas are plungers lifted by forks on the sliding bar connected to the choke lever/cable. If one of the plungers becomes stuck the fork will override it.

When the choke is turned off, the bar (with the other choke plungers) cannot return to the fully off position (because one of the forks is now sitting on top of the stuck choke) and the bike runs rich at idle.

If that's OK, your issue maybe the opposite of an overly lean mixture. If you’ve disturbed one of the carb balance take off blanks the bike will run lean on one cylinder. Check the blanking caps and anything tapped into the intake side like a Scottoiler.

Get yours at MCNshop.com