Skip to content

Ask an Expert No power after 6000rpm on Triumph TT600 Technical

You are in... Forums > Ask an Expert > Technical > No power after 6000rpm on Triumph TT600

Got something to say?

Got something to say?

Go to most recent reply

phil390

Joined:

Mar 12

Posts: 3

phil390 says:

No power after 6000rpm on Triumph TT600

I have got a Triumph TT600 and when you are riding the bike it will not go over 6,000 rpm's and loses power if you try. When the bike is on a paddock stand you can rev the bike over 12,000 rpm's and also if the bike is in gear on the stand agian it will rev over 12,000 rpm's. Could anyone help me sort this problem out so that I can enjoy riding the bike.

Reply to this Topic  
  • Posted 3 years ago (19 March 2012 22:45)

Post a message in Technical

Fields marked with an asterisk * are required

   

Please note. You cannot submit more than 4000 characters as a message.

Upload image(s) from your computer (up to 3 images)

  1.  
  2.  
  3.  

Terms of use

Use of our community areas and forums is subject to important terms of use. By joining our community and using the features you agree to be bound by these terms. See terms of use below. 

Cancel
jaffa90

Joined:

Mar 09

Posts: 8996

jaffa90 says:

tt600

Welcome phil,your model has been on here a few times with problems and recalls being the first injection model.An engine under load uses a lot more fuel than being on a paddock stand,so fuel pressure delivery may be the problem or one of many of the sensors on a fuel injected bike.There`s one or two pro`s on here and mostly kcmc from sunny down under will have more idea. 

Reply to this Topic
kcmc

Joined:

Jan 08

Posts: 7720

kcmc says:

Triumph TT600 Year??

Hi Phil390 and welcome to the sit:smile

You don't give much info to go on:upset:not even the year of your bike,the early TT600 had significant fueling problems and needed remapping by a main dealer to sort of sort the problem(this was mainly bottom end choppy on off throttle).The other problem it seems with the TT6 seems to be stick coils breaking down(arcing out down the spark plug tunnel),like the older Yamaha R6?.Like i said you don't give much info so this is all guess work anyway:wacko:,has it just started to do this or has it been slowly getting worse?have you fitted any after market parts(exhaust can sports air filter).A quick and easy thing to try first is to put a 100-150ml of methylated spirit in the fuel tank with a full tank of fuel to take any water or moisture out of the tank and injection system.Run this though to see if things improve,but with the bike being i presume about ten years old it could be part of the first ever fuel injection system that Triumph did starting to break down(one of the sensors?)Hope this helps in some way? Good Luck

KCMC:tongue:

Reply to this Topic
phil390

Joined:

Mar 12

Posts: 3

phil390 says:

Triumph TT600

Thanks for getting back kcmc, sorry about the limited info I gave. The bike is from 2002 and I got it off my father in-law, the trouble was that it had not been riden for about 3 years when I got the bike. I put on a new battery and changed the oil and fuel even though it had only done about 150 miles since it's last service. The problem as been there since I got the bike. Do you think that I still need to follow your previous instructions or will this new information change your thoughts.

Reply to this Topic
phil390

Joined:

Mar 12

Posts: 3

phil390 says:

Triumph TT600

Thanks for getting back in touch jaffa90. Following your advice

Reply to this Topic
kcmc

Joined:

Jan 08

Posts: 7720

kcmc says:

Triumph TT600 2002

Hi Phil

I would give the metho a try if your riding the bike,nothing to lose?if you have no results with this then it could be worth running a diagnostic test(sorry don't know how to do this on your bike)take it to a main dealer if you don't know the fault codes and how to obtain them.With being left for some time with a dead battery this also could have caused a problem with the electronics and ECU,this would also show on the diagnostic test.As i said before these bikes also suffer with stick coil break down(ignition coils)but it could also be a fuel pump,or pump relay malfunctioning.So after the metho test it could be a good idea to have the diagnostic test done before spending on parts you may not need until maybe you find the fault?Good Luck

KCMC:tongue:

Reply to this Topic
triumphrider600

Joined:

Feb 09

Posts: 548

You could try

putting the ecu in adaptive mode, as without battery power for 3 years there maybe issues with the map.

On the TT start the bike on the side stand and touch NOTHING, don't rev it just start it. Just let it idle until the cooling fan kicks in, when the fan has stopped ride off and it will reset all the base settings and adapt the throttle to your riding.

Tom


Reply to this Topic
jaffa90

Joined:

Mar 09

Posts: 8996

jaffa90 says:

top end

Could it be possible that the injectors are partly blocked gummed up and restricting fuel flow and over advancing the ignition timing with turning the throttle more?:unsure:

It`s been stopped/laid up a long while and i have limited knowledge with petrol injection. 

Reply to this Topic

Page

Compare Insurance

Save money by comparing quotes. It's quick and easy

Motorcycles for sale

 

It's only £13.99 to advertise your motorcycle on MCN

Sell your Motorcycle

Motorcycle pricing tool

New! Find used bike prices