Skip to content

Ask an Expert Triumph 955i Technical

You are in... Forums > Ask an Expert > Technical > Triumph 955i

Got something to say?

Got something to say?

Go to most recent reply

JRWill

Joined:

Nov 12

Posts: 1

JRWill says:

Triumph 955i

My (2000) Daytona 955i to start, is fuel injected, but there is hesitation in the throttle currently and it sometimes dies when in idle or after i hit the throttle downshifting and coming to a stop. Could i have given the bike bad gas, and if so, what now can i do to rectify it? Should i treat it like a car and put gas treatment solution in to help, along with super or plus instead of regular fuel??

[This Topic has been modified by the Author]

Reply to this Topic  
  • Posted 2 years ago (20 November 2012 03:45)

Post a message in Technical

Fields marked with an asterisk * are required

   

Please note. You cannot submit more than 4000 characters as a message.

Upload image(s) from your computer (up to 3 images)

  1.  
  2.  
  3.  

Terms of use

Use of our community areas and forums is subject to important terms of use. By joining our community and using the features you agree to be bound by these terms. See terms of use below. 

Cancel
kcmc

Joined:

Jan 08

Posts: 7080

kcmc says:

Triumph Daytona 955i 2000

Hi JRWill and welcome to the site,why no profile?are you a spy :lol: or do you have something to hide? any way welcome:smile

Is there a reason you think you may have put contaminated fuel in your bike?if so what sort of contamination would this be? this would be info anybody would need to give advice without having to speculate.Good Luck

KCMC:tongue:

Reply to this Topic
paulderekjohnson

Joined:

Feb 08

Posts: 1952

First thing to check

Make sure the overlow drain pipe isn't blocked or nipped,leading to water ingress everytime you open the filler cap. If it is,unblock it (may need to actually run some stiff wire down the hole as thye can gum up badly) then dump the fuel and replace it with fresh. If not that,have it plugged in at a dealer and check that the stepper motor is working

Reply to this Topic
darren997

Joined:

Aug 02

Posts: 5

darren997 says:

IACV hoses

That sounds like problem with the IACV hoses. I had the same problem on my 99 daytona.
Here a read of this link
http://www.triumphtorque.com/messageboard/thread/103885-IACV-air-leaks-brittle-rubber-connectors.aspx?highlight=iavc


Reply to this Topic
Dabbsy

Joined:

Aug 02

Posts: 485

Dabbsy says:

TPS o-ring swelling

If it's cutting out when you blip the throttle it could be that the o-ring behind the throttle position sensor has swollen and is catching on the throttle potentiometer, so it doesn't rotate freely and sends spurious messages to the ECU causing the cut-out. the TPS is on the end of the throttle bodies and it's easy to remove the cover and replace the o-ring. The only tricky bit is resetting the tps accurately as it has no stop position at either idle or full-throttle. you really need to hook it up to a laptop or diagnostic tool to set it at a certain voltage for the idle position. Though I suppose you could mark it before removing and see if that visual method works first.

Reply to this Topic

Page

Compare Insurance

Save money by comparing quotes. It's quick and easy

Motorcycles for sale

 

It's only £13.99 to advertise your motorcycle on MCN

Sell your Motorcycle

Motorcycle pricing tool

New! Find used bike prices