Skip to content

Ask an Expert Bonneville EFI Tors exhaust Technical

You are in... Forums > Ask an Expert > Technical > Bonneville EFI Tors exhaust

Got something to say?

Got something to say?

Go to most recent reply

saxman16

Joined:

Feb 13

Posts: 2

saxman16 says:

Bonneville EFI Tors exhaust

Hi, my local Triumph dealer has recently fitted Tors exhausts to my Bonnie EFI and carried out the remap. bike sounds great and has been running great until I did a fairly long trip and it wouldn't restart when hot. Did this a couple of times lots of coaching and sputtering, waited a bit then eventually fired up and was ok all the way home. When cold it fires first time. Dealer says this happens sometime and to turn ignition on and off a few times when hot , the ecu will reset.

Any advice I'm concerned I'm going to get stuck on a ride out
Many thanks


Reply to this Topic  
  • Posted 2 years ago (19 February 2013 19:34)

Post a message in Technical

Fields marked with an asterisk * are required

   

Please note. You cannot submit more than 4000 characters as a message.

Upload image(s) from your computer (up to 3 images)

  1.  
  2.  
  3.  

Terms of use

Use of our community areas and forums is subject to important terms of use. By joining our community and using the features you agree to be bound by these terms. See terms of use below. 

Cancel
banditsprint

Joined:

Oct 08

Posts: 54

banditsprint says:

TPS reset

Could be that you need a TPS reset at your dealer. 


Switching ignition on and off repeatedly will not reset anything.

Reply to this Topic

Page

Compare Insurance

Save money by comparing quotes. It's quick and easy

Motorcycles for sale

 

It's only £13.99 to advertise your motorcycle on MCN

Sell your Motorcycle