Skip to content

Ask an Expert Yamaha ybr 125 rear light Technical

You are in... Forums > Ask an Expert > Technical > Yamaha ybr 125 rear light

Got something to say?

Got something to say?

Go to most recent reply

wato08

Joined:

Mar 13

Posts: 2

wato08 says:

Yamaha ybr 125 rear light

Help please!!! rear light does not work, I have checked the bulb as there is only 1 working with the brake light and no problem there, also since the light went out the indicators don't flash just stay solid any suggestions would be great as im new to riding and want to learn

Reply to this Topic  
  • Posted 2 years ago (06 March 2013 17:29)

Post a message in Technical

Fields marked with an asterisk * are required

   

Please note. You cannot submit more than 4000 characters as a message.

Upload image(s) from your computer (up to 3 images)

  1.  
  2.  
  3.  

Terms of use

Use of our community areas and forums is subject to important terms of use. By joining our community and using the features you agree to be bound by these terms. See terms of use below. 

Cancel
jaffa90

Joined:

Mar 09

Posts: 8817

jaffa90 says:

rear light

Welcome wato08 with a hidden profile,have you tried the indicators with the bulb removed?

Can you see if one of the two the filaments (wires inside the bulb) are broke?

Can you see any bare/cut/worn wires leading to the rear light or indicators?

The bulb has offset holding pins and twin soldered live nipples/connections if what you say.   

[This Reply has been modified by the Author]

Reply to this Topic
wato08

Joined:

Mar 13

Posts: 2

wato08 says:

solid indicators

Cheers for the reply Jaffa 90 ive sorted the rear light out (it was a loose connection under the seat pan, however the indicators are still solid scratching my head at this one. Any advice would be appreciated. 

Reply to this Topic
jaffa90

Joined:

Mar 09

Posts: 8817

jaffa90 says:

lights

Profile,no need for photo pics or real name,just age/bikes/area as in Lancashire.

I`m scratching my head now and i`ve more hair than you (just).Solid flashers can mean low voltage going to them (more so on tickover),or too higher wattage bulbs (yours did work).Also if current is going somewhere else in the circuits.Still confused i would check all flasher bulbs/connectors for corrosion.

Remember that more electrical resistance you have in a flasher circuit the more chance the flasher relay will work (bi-metal strip).:blink:

Reply to this Topic
kcmc

Joined:

Jan 08

Posts: 7171

kcmc says:

Yamaha YBR 125 Year? Miles?

Hi Wato08

This sounds like just a duff battery,are you using the kick starter because the bike wont start on the button? if so you just need a good battery and your problems will be solved.If it is a dead battery and you persist in using the kick start,(no problem doing this with a good battery)the charge system will work itself to death trying to charge a duff battery and damage the regulator rectifier and eventually the lighting coils.Good Luck

KCMC:tongue:

Reply to this Topic

Page

Compare Insurance

Save money by comparing quotes. It's quick and easy

Motorcycles for sale

 

It's only £13.99 to advertise your motorcycle on MCN

Sell your Motorcycle

Motorcycle pricing tool

New! Find used bike prices