Skip to content

Ask an Expert Piaggio Typhoon 125 starting issues Technical

You are in... Forums > Ask an Expert > Technical > Piaggio Typhoon 125 starting issues

Got something to say?

Got something to say?

Go to most recent reply

obutler1

Joined:

Apr 13

Posts: 1

obutler1 says:

Piaggio Typhoon 125 starting issues

I was wondering if anyone could help.

I have a piaggio typhoon 125 2 stoke that has sat for a year.

I have put on a fully charged brand new battery which powers all the lights fine, but the battery light still comes on when I turn on the ignition.

when I kick the engine over there is no spark on the spark plug which is in good condition. also when I press the electric start button nothing happens.

any body have any ideas as to what could be causing this?

i've checked all connections and everything seems fine.

cheers

[This Topic has been modified by the Author]

Reply to this Topic  
  • Posted 2 years ago (14 April 2013 10:20)

Post a message in Technical

Fields marked with an asterisk * are required

   

Please note. You cannot submit more than 4000 characters as a message.

Upload image(s) from your computer (up to 3 images)

  1.  
  2.  
  3.  

Terms of use

Use of our community areas and forums is subject to important terms of use. By joining our community and using the features you agree to be bound by these terms. See terms of use below. 

Cancel
jaffa90

Joined:

Mar 09

Posts: 8788

jaffa90 says:

no start

Welcome obutler1,not familiar with your Piaggio but have you checked the kill switch or other safety switches which should be on/off as in neutral light?????????.It does sound like a safety device/alarm immobilizer???????.

[This Reply has been modified by the Author]

Reply to this Topic
kcmc

Joined:

Jan 08

Posts: 7077

kcmc says:

Piaggio Typhoon 125 year?

Hi Obutler1 and welcome to the site:smile

As Jaffa90 says check the engine kill switch is in the run position as this cuts the spark from the coil,also make sure you pull on both of the brakes,as again it will not turn over without the brake lever,levers pulled.Easy way to check,if you get a brake light on the switch is working,if your not getting a brake light there could be a problem with the brake light switches(or the bulb has blown)if the bulb is good the switchers are faulty(this is very commen on these bikes).If they are malfunctioning,you can pull the female spade ends off and join the wires together to start the bike until you can replace the stop light switches.Good Luck

KCMC:tongue: 

[This Reply has been modified by the Author]

Reply to this Topic

Page

Compare Insurance

Save money by comparing quotes. It's quick and easy

Motorcycles for sale

 

It's only £13.99 to advertise your motorcycle on MCN

Sell your Motorcycle

Motorcycle pricing tool

New! Find used bike prices